Wednesday, February 09, 2011

JSF2.0: Unable to load JSF2.0/Primefaces jars on Weblogic Server 10.3.2 start up

I think except for the option to upgrade to a new version or applying a patchset there is a workaround that i tried and it worked for me.

Problem
It occurs because weblogic 10 is shipped with Mojarra JSF 1.2 and the version that we want to make it work is Mojarra JSF 2.0.

Solution
It's a simple fix. In weblogic there is a file called commEnv.bat/sh. If you are running windows edit the bat file, else if you are running Linux/Mac edit the sh file.

Search for PRE_CLASSPATH or WEBLOGIC_CLASSPATH and add a complete path to the jsf-api.jar, jsf-impl.jar before weblogic.jar and if you are using Primefaces, just append it afterwords. Restart the server, deploy your application make sure that jsf-api.jar and jsf-impl.jar are there in the lib folder, but you are now free to remove the primefaces jar as it is already loaded by weblogic at server start-up otherwise you will see the same error still your application won't break.


Topic Discussed
http://forums.oracle.com/forums/thread.jspa?threadID=1043858&start=30&tstart=0
http://www.coderanch.com/t/486434/JSF/java/Unable-load-primefaces-jar-Weblogic

Hope this Helps! Please write your comments it will help me improve.

0 comments:

Post a Comment